import Foundation
let pattern = #"ส[ัา][สด]|สัตว์|เหี้ย"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
สัด
สาท
สาด
สัตว์
เหี้ย
ดกเดกเ
ดกเดกเ
กดเกดดเ
พะำ
นรีน
อือเ
ด้พะ
ะด้ด
เด้ดเ
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)