using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|\b)\d(?=\d{0,2}\.\d{1,3}\.)";
string substitution = @"x";
string input = @"10.101.11.11
101.11.11.11
2003.12.11";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}