use strict;
my $str = '10.101.11.11
101.11.11.11
2003.12.11';
my $regex = qr/(?:\G(?!^)|\b)\d(?=\d{0,2}\.\d{1,3}\.)/mp;
my $subst = 'x';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";