$re = '/(?:\G(?!^)|\b)\d(?=\d{0,2}\.\d{1,3}\.)/m';
$str = '10.101.11.11
101.11.11.11
2003.12.11';
$subst = "x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;