import Foundation
let pattern = #"(?:\G(?!^)|\b)\d(?=\d{0,2}\.\d{1,3}\.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
10.101.11.11
101.11.11.11
2003.12.11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"x"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)