const regex = new RegExp('(?:\\G(?!^)|\\b)\\d(?=\\d{0,2}\\.\\d{1,3}\\.)', 'gm')
const str = `10.101.11.11
101.11.11.11
2003.12.11`;
const subst = `x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);