#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^;\s*|;\s*$"
Local $sString = "; foo ;bar;" & @CRLF & _
"foo ;bar;" & @CRLF & _
"; foo ;bar" & @CRLF & _
"foo ;bar"
Local $sSubst = "<DEL>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)