import Foundation
let pattern = #"^;\s*|;\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
; foo ;bar;
foo ;bar;
; foo ;bar
foo ;bar
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<DEL>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)