re = /^;\s*|;\s*$/m
str = '; foo ;bar;
foo ;bar;
; foo ;bar
foo ;bar'
subst = '<DEL>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result