use strict;
my $str = '; foo ;bar;
foo ;bar;
; foo ;bar
foo ;bar';
my $regex = qr/^;\s*|;\s*$/mp;
my $subst = '<DEL>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";