$re = '/^;\s*|;\s*$/m';
$str = '; foo ;bar;
foo ;bar;
; foo ;bar
foo ;bar';
$subst = "<DEL>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;