using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Localize|Localizable)\s*\(\s*\""((?:(?:\\\"")|[^\""])+)\""(?:\s*,\s*\""((?:(?:\\\"")|[^\""])+)\"")?\s*\)";
string input = @"Expected Match 1: Localize(""Text"")
Expected Match 1: Localize(""\""Text\"")
Expected Match 1: Localize(""\""Text\""\\"")
Expected Match 1: Localize(""\""Text\"", \""\""Test"")
Expected Match 2: Localize(""Text"", ""Context"")
Expected Match 2: Localize(""\""Text\"", ""\""Context\"")
Expected Match 2: Localize(""\""Text\""\\"", ""\\\""Context\"")
Expected Match 2: Localize(""\""Text\"", \""\""Test"", ""Context\\"")
Expected Match 2: Localize(""\""\""'\""'\"")
Expected Unmatch: Localize(Variable)
Expected Unmatch: Localize(Variable, ""Context"")
Expected Unmatch: Localize(""Text"", Variable)
Compile Error: Localize(""\""Text"", Context\"")
Compile Error: Localize(""NonClosed, \""Context\"")
Compile Error: Localize(""\""Text\"")
Compile Error: Localize(""\""Text\"", ""Context\"")
Compile Error: Localize(""\""Text\"", ""\""Context"")";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}