re = /(Localize|Localizable)\s*\(\s*\"((?:(?:\\\")|[^\"])+)\"(?:\s*,\s*\"((?:(?:\\\")|[^\"])+)\")?\s*\)/
str = 'Expected Match 1: Localize("Text")
Expected Match 1: Localize("\\"Text\\"")
Expected Match 1: Localize("\\"Text\\"\\\\")
Expected Match 1: Localize("\\"Text\\", \\"\\"Test")
Expected Match 2: Localize("Text", "Context")
Expected Match 2: Localize("\\"Text\\"", "\\"Context\\"")
Expected Match 2: Localize("\\"Text\\"\\\\", "\\\\\\"Context\\"")
Expected Match 2: Localize("\\"Text\\", \\"\\"Test", "Context\\\\")
Expected Match 2: Localize("\\"\\"\'\\"\'\\"")
Expected Unmatch: Localize(Variable)
Expected Unmatch: Localize(Variable, "Context")
Expected Unmatch: Localize("Text", Variable)
Compile Error: Localize("\\""Text", Context\\"")
Compile Error: Localize("NonClosed, \\"Context\\")
Compile Error: Localize("\\"Text\\")
Compile Error: Localize("\\"Text\\", "Context\\")
Compile Error: Localize("\\"Text\\", "\\"Context")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end