import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Localize|Localizable)\\s*\\(\\s*\\\"((?:(?:\\\\\\\")|[^\\\"])+)\\\"(?:\\s*,\\s*\\\"((?:(?:\\\\\\\")|[^\\\"])+)\\\")?\\s*\\)";
final String string = "Expected Match 1: Localize(\"Text\")\n"
+ "Expected Match 1: Localize(\"\\\"Text\\\"\")\n"
+ "Expected Match 1: Localize(\"\\\"Text\\\"\\\\\")\n"
+ "Expected Match 1: Localize(\"\\\"Text\\\", \\\"\\\"Test\")\n"
+ "Expected Match 2: Localize(\"Text\", \"Context\")\n"
+ "Expected Match 2: Localize(\"\\\"Text\\\"\", \"\\\"Context\\\"\")\n"
+ "Expected Match 2: Localize(\"\\\"Text\\\"\\\\\", \"\\\\\\\"Context\\\"\")\n"
+ "Expected Match 2: Localize(\"\\\"Text\\\", \\\"\\\"Test\", \"Context\\\\\")\n"
+ "Expected Match 2: Localize(\"\\\"\\\"'\\\"'\\\"\")\n"
+ "Expected Unmatch: Localize(Variable)\n"
+ "Expected Unmatch: Localize(Variable, \"Context\")\n"
+ "Expected Unmatch: Localize(\"Text\", Variable)\n"
+ "Compile Error: Localize(\"\\\"\"Text\", Context\\\"\")\n"
+ "Compile Error: Localize(\"NonClosed, \\\"Context\\\")\n"
+ "Compile Error: Localize(\"\\\"Text\\\")\n"
+ "Compile Error: Localize(\"\\\"Text\\\", \"Context\\\")\n"
+ "Compile Error: Localize(\"\\\"Text\\\", \"\\\"Context\")";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}