use strict;
my $str = 'Expected Match 1: Localize("Text")
Expected Match 1: Localize("\\"Text\\"")
Expected Match 1: Localize("\\"Text\\"\\\\")
Expected Match 1: Localize("\\"Text\\", \\"\\"Test")
Expected Match 2: Localize("Text", "Context")
Expected Match 2: Localize("\\"Text\\"", "\\"Context\\"")
Expected Match 2: Localize("\\"Text\\"\\\\", "\\\\\\"Context\\"")
Expected Match 2: Localize("\\"Text\\", \\"\\"Test", "Context\\\\")
Expected Match 2: Localize("\\"\\"\'\\"\'\\"")
Expected Unmatch: Localize(Variable)
Expected Unmatch: Localize(Variable, "Context")
Expected Unmatch: Localize("Text", Variable)
Compile Error: Localize("\\""Text", Context\\"")
Compile Error: Localize("NonClosed, \\"Context\\")
Compile Error: Localize("\\"Text\\")
Compile Error: Localize("\\"Text\\", "Context\\")
Compile Error: Localize("\\"Text\\", "\\"Context")';
my $regex = qr/(Localize|Localizable)\s*\(\s*\"((?:(?:\\\")|[^\"])+)\"(?:\s*,\s*\"((?:(?:\\\")|[^\"])+)\")?\s*\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}