package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Localize|Localizable)\s*\(\s*\"((?:(?:\\\")|[^\"])+)\"(?:\s*,\s*\"((?:(?:\\\")|[^\"])+)\")?\s*\)`)
var str = `Expected Match 1: Localize("Text")
Expected Match 1: Localize("\"Text\"")
Expected Match 1: Localize("\"Text\"\\")
Expected Match 1: Localize("\"Text\", \"\"Test")
Expected Match 2: Localize("Text", "Context")
Expected Match 2: Localize("\"Text\"", "\"Context\"")
Expected Match 2: Localize("\"Text\"\\", "\\\"Context\"")
Expected Match 2: Localize("\"Text\", \"\"Test", "Context\\")
Expected Match 2: Localize("\"\"'\"'\"")
Expected Unmatch: Localize(Variable)
Expected Unmatch: Localize(Variable, "Context")
Expected Unmatch: Localize("Text", Variable)
Compile Error: Localize("\""Text", Context\"")
Compile Error: Localize("NonClosed, \"Context\")
Compile Error: Localize("\"Text\")
Compile Error: Localize("\"Text\", "Context\")
Compile Error: Localize("\"Text\", "\"Context")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}