const regex = new RegExp('(Localize|Localizable)\\s*\\(\\s*\\"((?:(?:\\\\\\")|[^\\"])+)\\"(?:\\s*,\\s*\\"((?:(?:\\\\\\")|[^\\"])+)\\")?\\s*\\)', 'g')
const str = `Expected Match 1: Localize("Text")
Expected Match 1: Localize("\\"Text\\"")
Expected Match 1: Localize("\\"Text\\"\\\\")
Expected Match 1: Localize("\\"Text\\", \\"\\"Test")
Expected Match 2: Localize("Text", "Context")
Expected Match 2: Localize("\\"Text\\"", "\\"Context\\"")
Expected Match 2: Localize("\\"Text\\"\\\\", "\\\\\\"Context\\"")
Expected Match 2: Localize("\\"Text\\", \\"\\"Test", "Context\\\\")
Expected Match 2: Localize("\\"\\"'\\"'\\"")
Expected Unmatch: Localize(Variable)
Expected Unmatch: Localize(Variable, "Context")
Expected Unmatch: Localize("Text", Variable)
Compile Error: Localize("\\""Text", Context\\"")
Compile Error: Localize("NonClosed, \\"Context\\")
Compile Error: Localize("\\"Text\\")
Compile Error: Localize("\\"Text\\", "Context\\")
Compile Error: Localize("\\"Text\\", "\\"Context")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}