import Foundation
let pattern = #"(Localize|Localizable)\s*\(\s*\"((?:(?:\\\")|[^\"])+)\"(?:\s*,\s*\"((?:(?:\\\")|[^\"])+)\")?\s*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Expected Match 1: Localize("Text")
Expected Match 1: Localize("\"Text\"")
Expected Match 1: Localize("\"Text\"\\")
Expected Match 1: Localize("\"Text\", \"\"Test")
Expected Match 2: Localize("Text", "Context")
Expected Match 2: Localize("\"Text\"", "\"Context\"")
Expected Match 2: Localize("\"Text\"\\", "\\\"Context\"")
Expected Match 2: Localize("\"Text\", \"\"Test", "Context\\")
Expected Match 2: Localize("\"\"'\"'\"")
Expected Unmatch: Localize(Variable)
Expected Unmatch: Localize(Variable, "Context")
Expected Unmatch: Localize("Text", Variable)
Compile Error: Localize("\""Text", Context\"")
Compile Error: Localize("NonClosed, \"Context\")
Compile Error: Localize("\"Text\")
Compile Error: Localize("\"Text\", "Context\")
Compile Error: Localize("\"Text\", "\"Context")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)