using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\btodo\b.*(?i)\bjundan\b.*";
string input = @"// todo - daniel junior - test
// todo jundan test
// TODO -jundan- asaksakjhdakjshdas
// TODOjundan - alijsakljsldk
/////// tODO-jundan batata";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}