$re = '/(?i)\btodo\b.*(?i)\bjundan\b.*/m';
$str = '// todo - daniel junior - test
// todo jundan test
// TODO -jundan- asaksakjhdakjshdas
// TODOjundan - alijsakljsldk
/////// tODO-jundan batata';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);