import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\btodo\\b.*(?i)\\bjundan\\b.*";
final String string = "// todo - daniel junior - test\n"
+ "// todo jundan test\n"
+ "// TODO -jundan- asaksakjhdakjshdas\n"
+ "// TODOjundan - alijsakljsldk\n"
+ "/////// tODO-jundan batata";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}