re = /(?i)\btodo\b.*(?i)\bjundan\b.*/m
str = '// todo - daniel junior - test
// todo jundan test
// TODO -jundan- asaksakjhdakjshdas
// TODOjundan - alijsakljsldk
/////// tODO-jundan batata'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end