// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)\btodo\b.*(?i)\bjundan\b.*").unwrap();
let string = "// todo - daniel junior - test
// todo jundan test
// TODO -jundan- asaksakjhdakjshdas
// TODOjundan - alijsakljsldk
/////// tODO-jundan batata";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}