import re
regex = re.compile(r"\/(\s)?")
test_str = ("hands/fingers/ feet\n"
"hands/fingers/feet\n\n"
"Human have hands/fingers/ feet and so on\n"
"Humanhavehands/ fingers/ feetandsoon")
subst = "/ "
result = regex.sub(subst, test_str)
if result:
print(result)