#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!-$)(?:-?[0-9]{0,4})(?:\.[0-9]{1,4})?$"
Local $sString = "1234" & @CRLF & _
"-" & @CRLF & _
"1234-123213" & @CRLF & _
"-1234" & @CRLF & _
"-12323-2323-233" & @CRLF & _
"1234.1234" & @CRLF & _
"-1234.1212"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")