using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!-$)(?:-?[0-9]{0,4})(?:\.[0-9]{1,4})?$";
string input = @"1234
-
1234-123213
-1234
-12323-2323-233
1234.1234
-1234.1212";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}