const regex = /^(?!-$)(?:-?[0-9]{0,4})(?:\.[0-9]{1,4})?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!-$)(?:-?[0-9]{0,4})(?:\\.[0-9]{1,4})?$', 'gmi')
const str = `1234
-
1234-123213
-1234
-12323-2323-233
1234.1234
-1234.1212`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}