re = /^(?!-$)(?:-?[0-9]{0,4})(?:\.[0-9]{1,4})?$/mi
str = '1234
-
1234-123213
-1234
-12323-2323-233
1234.1234
-1234.1212'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end