use strict;
my $str = '1234
-
1234-123213
-1234
-12323-2323-233
1234.1234
-1234.1212';
my $regex = qr/^(?!-$)(?:-?[0-9]{0,4})(?:\.[0-9]{1,4})?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}