import re
regex = re.compile(r"^(?!-$)(?:-?[0-9]{0,4})(?:\.[0-9]{1,4})?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("1234\n"
"-\n"
"1234-123213\n"
"-1234\n"
"-12323-2323-233\n"
"1234.1234\n"
"-1234.1212")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")