import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!-$)(?:-?[0-9]{0,4})(?:\\.[0-9]{1,4})?$";
final String string = "1234\n"
+ "-\n"
+ "1234-123213\n"
+ "-1234\n"
+ "-12323-2323-233\n"
+ "1234.1234\n"
+ "-1234.1212";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}