using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<u\+[0-9a-f]{4}>";
string substitution = @"";
string input = @"mr<u+092d>a<u+093e>b<u+0935>55<u+0941><u+0915> de 9 0u";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}