import Foundation
let pattern = #"<u\+[0-9a-f]{4}>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"mr<u+092d>a<u+093e>b<u+0935>55<u+0941><u+0915> de 9 0u"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)