const regex = new RegExp('<u\\+[0-9a-f]{4}>', 'gm')
const str = `mr<u+092d>a<u+093e>b<u+0935>55<u+0941><u+0915> de 9 0u`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);