use strict;
my $str = 'mr<u+092d>a<u+093e>b<u+0935>55<u+0941><u+0915> de 9 0u';
my $regex = qr/<u\+[0-9a-f]{4}>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";