package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((\d{1,3})\.)(\d){1,3}|((\d{3}(\,))*)(\d{1,3})(\.\d{1,3})*)$`)
var str = `3.5
30.50
3,500
3,500.555
300,500.555
0.5
0,5
00,5
300,000,500.555
300,000,500
1,000,005.5
12,5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}