$re = '/^(((\d{1,3})\.)(\d){1,3}|((\d{3}(\,))*)(\d{1,3})(\.\d{1,3})*)$/m';
$str = '3.5
30.50
3,500
3,500.555
300,500.555
0.5
0,5
00,5
300,000,500.555
300,000,500
1,000,005.5
12,5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);