package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\+|00)88|01)?(?:\d{11}|\d{13})$`)
var str = `+8812345678901
+88123456789012
+881234567890123
+8812345678901234
0112345678901
01123456789012
011234567890123
0112345678901234
+8812345678901
0112345678901
12345678901
+8801812598624
008801812598624
01812598624
01712598624
01672598624
01919598624
01419598624
01319598624`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}