$re = '/^(?:(?:\+|00)88|01)?(?:\d{11}|\d{13})$/m';
$str = '+8812345678901
+88123456789012
+881234567890123
+8812345678901234
0112345678901
01123456789012
011234567890123
0112345678901234
+8812345678901
0112345678901
12345678901
+8801812598624
008801812598624
01812598624
01712598624
01672598624
01919598624
01419598624
01319598624';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);