# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:\+|00)88|01)?(?:\d{11}|\d{13})$"
test_str = ("+8812345678901\n"
"+88123456789012\n"
"+881234567890123\n"
"+8812345678901234\n"
"0112345678901\n"
"01123456789012\n"
"011234567890123\n"
"0112345678901234\n\n"
"+8812345678901\n"
"0112345678901\n"
"12345678901\n"
"+8801812598624\n"
"008801812598624\n"
"01812598624\n"
"01712598624\n"
"01672598624\n"
"01919598624\n"
"01419598624\n"
"01319598624")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.