const regex = /^(?:(?:\+|00)88|01)?(?:\d{11}|\d{13})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\+|00)88|01)?(?:\\d{11}|\\d{13})$', 'gm')
const str = `+8812345678901
+88123456789012
+881234567890123
+8812345678901234
0112345678901
01123456789012
011234567890123
0112345678901234
+8812345678901
0112345678901
12345678901
+8801812598624
008801812598624
01812598624
01712598624
01672598624
01919598624
01419598624
01319598624`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}