import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\+|00)88|01)?(?:\\d{11}|\\d{13})$";
final String string = "+8812345678901\n"
+ "+88123456789012\n"
+ "+881234567890123\n"
+ "+8812345678901234\n"
+ "0112345678901\n"
+ "01123456789012\n"
+ "011234567890123\n"
+ "0112345678901234\n\n"
+ "+8812345678901\n"
+ "0112345678901\n"
+ "12345678901\n"
+ "+8801812598624\n"
+ "008801812598624\n"
+ "01812598624\n"
+ "01712598624\n"
+ "01672598624\n"
+ "01919598624\n"
+ "01419598624\n"
+ "01319598624";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}