use strict;
my $str = '+8812345678901
+88123456789012
+881234567890123
+8812345678901234
0112345678901
01123456789012
011234567890123
0112345678901234
+8812345678901
0112345678901
12345678901
+8801812598624
008801812598624
01812598624
01712598624
01672598624
01919598624
01419598624
01319598624';
my $regex = qr/^(?:(?:\+|00)88|01)?(?:\d{11}|\d{13})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}