import Foundation
let pattern = #"^(?:(?:\+|00)88|01)?(?:\d{11}|\d{13})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+8812345678901
+88123456789012
+881234567890123
+8812345678901234
0112345678901
01123456789012
011234567890123
0112345678901234
+8812345678901
0112345678901
12345678901
+8801812598624
008801812598624
01812598624
01712598624
01672598624
01919598624
01419598624
01319598624
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)