package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^₹ (([0-9]+\,[0-9]+)|([0-9]+[.]?[0-9]*(?:L|Cr)?))$`)
var str = `₹ 3.50L
₹ 3.50
₹ 3,500
₹ 30000000.50Cr
₹ 99.50L
₹ 3L
₹ 300.50Cr
₹ 350Cr
₹ 1
₹ 3,500L
₹ 3,500L
₹ 35,000L
₹ 3,500Cr
₹ 0,000Cr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}