const regex = /^₹ (([0-9]+\,[0-9]+)|([0-9]+[.]?[0-9]*(?:L|Cr)?))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^₹ (([0-9]+\\,[0-9]+)|([0-9]+[.]?[0-9]*(?:L|Cr)?))$', 'gm')
const str = `₹ 3.50L
₹ 3.50
₹ 3,500
₹ 30000000.50Cr
₹ 99.50L
₹ 3L
₹ 300.50Cr
₹ 350Cr
₹ 1
₹ 3,500L
₹ 3,500L
₹ 35,000L
₹ 3,500Cr
₹ 0,000Cr`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}