#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b'\b(*SKIP)(*F)|'"
Local $sString = "I don't know 'how' to remove these ' things"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)