import re
regex = re.compile(r"\b'\b(*SKIP)(*F)|'")
test_str = "I don't know 'how' to remove these ' things"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)