using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b'\b(*SKIP)(*F)|'";
string substitution = @"";
string input = @"I don't know 'how' to remove these ' things";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}