const regex = /\b'\b(*SKIP)(*F)|'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\'\\b(*SKIP)(*F)|\'', 'g')
const str = `I don't know 'how' to remove these ' things`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);